SWBF CUSTOM

The best way to custom your games.
 
HomeFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 [FAQ]Fix the era not showing up on mp selection screen bug

View previous topic View next topic Go down 
AuthorMessage
Lephenix
Scout Trooper Sergeant
Scout Trooper Sergeant
avatar

Messages : 833
Registration Date : 2010-05-05
Age : 22

PostSubject: [FAQ]Fix the era not showing up on mp selection screen bug   2/2/2011, 3:42 pm

Your mod or your era don't show in the mp selection screen ? Well , i have found how to fix that .

Open your addme lua :

Code:
--Search through the missionlist to find a map that matches mapName,
--then insert the new flags into said entry.
--Use this when you know the map already exists, but this content patch is just
--adding new gamemodes (otherwise you should just add whole new entries to the missionlist)
function AddNewGameModes(missionList, mapName, newFlags)
   for i, mission in missionList do
      if mission.mapluafile == mapName then
         for flag, value in pairs(newFlags) do
            mission[flag] = value
         end
      end
   end
end




--insert totally new maps here:
local sp_n = 0
local mp_n = 0
sp_n = table.getn(sp_missionselect_listbox_contents)



mp_n = table.getn(mp_missionselect_listbox_contents)
mp_missionselect_listbox_contents[mp_n+1] = sp_missionselect_listbox_contents[sp_n+1]

-- associate this mission name with the current downloadable content directory
-- (this tells the engine which maps are downloaded, so you need to include all new mission lua's here)
-- first arg: mapluafile from above
-- second arg: mission script name
-- third arg: level memory modifier.  the arg to LuaScript.cpp: DEFAULT_MODEL_MEMORY_PLUS(x)

AddNewGameModes( sp_missionselect_listbox_contents, "cor1%s_%s", {era_* = 1, mode_con_* = 1, change = {
era_*= { name="***", icon2="***" },
},})

AddDownloadableContent("GTM","GTMg_con",4)
AddDownloadableContent("GTM","GTMc_con",4)
AddDownloadableContent("GTM","GTMg_eli",4)
AddDownloadableContent("cor1","cor1t_con",4)

-- all done
newEntry = nil
n = nil


Just add that line :

Code:
AddNewGameModes( mp_missionselect_listbox_contents, "cor1%s_%s", {era_* = 1, mode_con_* = 1, change = {
era_*= { name="***", icon2="***" },
},})

Under :

Code:
AddNewGameModes( sp_missionselect_listbox_contents, "cor1%s_%s", {era_* = 1, mode_con_* = 1, change = {
era_*= { name="***", icon2="***" },
},})

Now your mod show up in MP selection screen 8) .

EDIT:Replace the *** with your names and letters .
Back to top Go down
View user profile http://lephenixbeginnings.blogspot.fr/
 

[FAQ]Fix the era not showing up on mp selection screen bug

View previous topic View next topic Back to top 
Page 1 of 1

 Similar topics

-
» Showing Appreciation to High Level Friends
» Mods not showing In game
» Pupil creation panel not showing on .ES
» DGSWEEPER help
» MM app store rating

Permissions in this forum:You cannot reply to topics in this forum
SWBF CUSTOM :: Star Wars Battlefront Games :: Modding-